Setting up help required

I’m hoping someone can help.
If this is in the wrong category, I apologise.
I am setting up my Raspberry Pi 3 B+ as a cloud server with an external 2tb ssd but I’m having problems configuring and connecting the ssd through the OwnCloud external storage interface so I would appreciate it if someone could explain in plain English, please, how to configure OwnCloud to connect to ssd external storage.
Should I have ‘Local’ as external storage? If so it doesn’t appear in the ‘Add storage’ dropdown list. What should go in the ‘Authentication ‘ and ‘Configuration’ boxes?
Sorry to be so naive but as a novice, I find the OwnCloud user guide somewhat difficult to follow.
I’m new to Raspberry Pi, Dietpi and OwnCloud.
The ssd is formatted and ready for use according to the Diepi storage interface.

You’re right, the Server-> Help category would fit.

For the storage: You have to add a line

'files_external_allow_create_new_local' => true,

to your config.php. After that, you’ll have a ‘Local’ option in the selection. Keep in mind that for the access rights the same rules apply, it must be writable by the user that is running the web-server.

1 Like

Thank you Alfredb for your response.

It took me a while to locate config.php but yes it’s working fine now except for one thing, ‘External storage has been disabled by the administrator’ still shows in Settings/storage, in other words the external drive is not displaying its content of 3 new folders on the OwnCloud home page. ‘Enable external storage’ in admin settings has been ticked.

Any suggestions would be appreciated.

Thank you

MikeAlan

Hi @MikeAlan, as you have opened in the wrong category, I’ll not continue to respond here. Please ask again in a new thread in the Server category.

I moved the thread to the server category.

There are two ways to add external storage. Once as admin and another time as user. If you want to add it as user, you need to specifically allow it in the admin settings. I think the checkbox in the interface for that is in the admin external storage settings.

@MikeAlan Could you solve your issue?

1 Like

Hi Alfredb,

No is the simple answer! Firstly I’ve been tied up in building 2 websites, which has taken me away from the Raspberrypi and second, now back on the RPi, I cant get OwnCloud to recognise the external ssd.
Dietpi-drive_manager Status says the ‘Drive is online and ready for use’.
The OwnCloud home page shows 3 default folders on the 16gb microchip that’s holds DietPi and OwnCloud.
The external 2tb ssd has also 3 folders I created just after formatting the drive and only visible when clicking on ‘External storage’ in admin/settings, these have the green circles showing. I cannot access these folders. Clicking on the folder name returns you to the default folders!
Uploading a single image, stores it on the 16gb microchip.
The ‘Use external storage’ box has been ticked’.

So you see I’m getting nowhere fast! Any help would be appreciated.

Thank you

You didn’t tell what filesystem the drive is formatted, and how it is mounted. I assume some access rights are missing.

The drive was formatted using EXT4. I was informed that this was the simplest one to use. I am happy to reformat and start again if you have other suggestions. FAT32 ?
I didnt pay much attention to how its mounted but just hoping to use the defaults! This could probably be where the problem lies.

I have just found the following article: https://www.raspberrypi.org/documentation/external-storage.md for External storage configuration. I shall follow these instructions unless you can advise otherwise.

Thank you
Michael

I’m not an expert on that topic and I don’t know nor have any raspi. But I know, also from the docs, that the HTTP server user must have r/w access rights for any storage attached to owncloud. And AFAIR, access rights always default to root.

A look at this page might help you finding a suitable configuration:

1 Like

NO! You need a posix filesystem, so EXT4 is good, FAT32 not. (also you wouldn’t be able to save files larger than 2GB…)