Slow Sync for LAN-based ownCloud Client -> Server

sync

#1

Hey Guys -

I set up ownCloud 10 in containers this morning and am syncing to it using my desktop client now. The folder is ~40gb of data and does include many files, however; it has only synced 1gb over the past 3-4 hours. Both the workstation and the container are connected via a gigabit switch and uploading files to the host is much faster than the speed the sync is operating at.

To note, my client is configured to access it via https://mydomain.com/owncloud which goes through an NGINX reverse proxy hosted on the same system as the client. I have also verified that it is not going out to the internet as I have a hosts entry on the PC to point mydomain.com to the local IP which I verified with a tracert. The NGINX conf file converts https://mydomain.com/owncloud to http://192.168.0.21:8282/owncloud which is local.

I tried a workaround of uploading files to the “files” folder via SCP then setting permissions to match other synced files, but they didn’t appear in the web console so deleted them.

I looked in owncloud.log, but the only two entries are from when I mistyped my credentials when initially logging into the web interface.

Any suggestions? I didn’t know if there were some tweaks I could use.

Thanks!!


#2

Size shouldn’t be the problem. Could you tell us more about the number of files you’re syncing?

I played a bit a while ago:

When you use SCP, you’d need to use the occ files:scan to update the database:
https://doc.owncloud.org/server/10.0/admin_manual/configuration/server/occ_command.html#the-files-scan-command