Upgrade owncloud from 8.0.x to 10


#1

I've been tasked with upgrading an owncloud server from 8.0.x to 10 on a Centos 7 Platform. Could someone please recommend the best way of doing this?

Many thanks


Upgrade to current version
#2

Production environment? You should wait for 10.0.1 ... Otherwise the documentation about upgrades is very helpfull. Do NOT skip a major version ... https://doc.owncloud.org/server/10.0/admin_manual/maintenance/upgrade.html


#3

Adding to this the following upgrade path is needed:

8.0.x -> latest 8.0.x -> latest 8.1.x -> latest 8.2.x -> latest 9.0.x -> latest 9.1.x (stop here until 10.0.1 or 10.0.2 is released)

by following the manuals provided above.


#4

Many thanks will give that a try!


#5

Many thanks again that worked! I stopped at 9.1.5.2.


#6

Where can I get latest 8.1.x?


#7

#8

I have the problem that my webhoster has disabled php 5.x and now only php 7.2 is possible. But with php 7.2 I can not upgrade by the cascade, cause oc 8.x doesnt work with php 7.2
Are there any other ways to get my 8.2.2 oC to 10.0.10 with only php 7.2 present?


#9

How may users do you have?


#10

not that much - only 3 users


#11

Then you can do a fresh install, keeping the existing data directory in place.


#12

i already tried that. I used the old config.php and edit the “version” to 10.0.10.4" that prevent the “can not update across major version”-message. Now I get a “App-Update is necessary”-message. When i click the updatebutton I get
" OC\RepairException: Upgrade is not possible" and
“Please install or update the following apps manually or disable them with:
occ app:disable files_videoviewer
occ app:disable updater”

I have no possibility to run occ local on server - I can access only via web or ftp
any hints?


#13

This is not a fresh install. For a fresh install, you have to delete everything, but NOT the data folder. Create a new database or delete all the tables.

BUT DO A BACKUP FIRST!

You also have to create new user accounts after the install. This is why I was asking you for the number of users.


#14

I placed a dummy.php with exec(“php occ /path/to/oc app disable …”); and run that. After this oc was running fine :slight_smile: but the calender has changed its internal database - so not calenders was shown.
With a real fresh install i assume the same problem with the calendar.
I decided to migrate the calenderentries by hand.

But thank you alfred for your helping words.


#15

Interesting idea! Thanks for that.