You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18


#1
    {"reqId":"WSAi7xOuF2A0NGwiYnchtQAAAAI","level":3,"time":"2017-05-20T11:05:20+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"--","app":"PHP","method":"GET","url":"\/index.php","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
{"reqId":"WSAi8BOuF2A0NGwiYnchtgAAAAI","level":3,"time":"2017-05-20T11:05:20+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"--","app":"PHP","method":"GET","url":"\/index.php\/login","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
{"reqId":"WSAi8hOuF2A0NGwiYnchtwAAAAI","level":3,"time":"2017-05-20T11:05:22+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"--","app":"PHP","method":"GET","url":"\/index.php\/core\/js\/oc.js?v=4db46dada417d6e4374527de9a59d8b7","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
{"reqId":"WSAi9ROuF2A0NGwiYnchuQAAAAI","level":3,"time":"2017-05-20T11:05:26+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"admin","app":"PHP","method":"POST","url":"\/index.php\/login","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
{"reqId":"WSAi9xOuF2A0NGwiYnchugAAAAI","level":3,"time":"2017-05-20T11:05:27+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"--","app":"PHP","method":"GET","url":"\/index.php\/apps\/files\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
{"reqId":"WSAi9xOuF2A0NGwiYnchuwAAAAI","level":3,"time":"2017-05-20T11:05:27+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"--","app":"PHP","method":"GET","url":"\/index.php\/login?redirect_url=%252Findex.php%252Fapps%252Ffiles%252F","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}
{"reqId":"WSAi@ROuF2A0NGwiYnchvAAAAAI","level":3,"time":"2017-05-20T11:05:29+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"--","app":"PHP","method":"GET","url":"\/index.php\/core\/js\/oc.js?v=4db46dada417d6e4374527de9a59d8b7","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}

Already searched, I can not solve this problem, who faced, tell me.

Centos7
OwnCloud10
Php 5.6


There were problems with the code integrity check. More information
Cert expired and updated php website gives 500 error
#2

As the message is telling you the PHP extension intl needs to be installed and enabled on your system. How this can be achieved is nothing ownCloud specific and heavily depends on your used linux distro.

For Ubuntu/Debian that would be (depending on your used PHP):

apt-get install php5-intl
apt-get install php7.0-intl
apt-get install php7.1-intl

For your used CentOS those commands are different. If you don't know how to install these on your CentOS please ask for some help on a community dedicated to CentOS.


#3

Installed

yum install php-intl

Restarted apache, did not help.

Restarted the server, it did not help.

The error in the logs is the same


#4

Then please follow my advise above as this is really nothing ownCloud specific and you should ask people familiar with your linux distribution when having such issues:


#6

I was having php-commom from remi repositories, so I used php-intl from remi also.

Add--enable-repo option as follows:

yum --enablerepo=remi install php-intl


#7

Thanks for sharing what worked for you :slight_smile:


#8

sudo apt-get install php-intl && sudo /etc/init.d/apache2 restart
This worked for me on a ubuntu server.